# Kong plugin configuration validation

**URL:** https://discuss.konghq.com/t/kong-plugin-configuration-validation/6240
**Category:** General
**Created:** [May 8, 2020, 2:11pm UTC](https://discuss.konghq.com/t/kong-plugin-configuration-validation/6240 "2020-05-08T14:11:25Z")
**Posts on this page:** 4
**Page:** 1

<div class="post-metadata">

### Author: ![Hamed\_Hatami](https://yyz2.discourse-cdn.com/flex036/user_avatar/discuss.konghq.com/hamed_hatami/32/1672_2.png) [@Hamed\_Hatami](https://discuss.konghq.com/u/Hamed_Hatami)
#### Post date: [May 8, 2020, 2:11pm UTC](https://discuss.konghq.com/t/kong-plugin-configuration-validation/6240/1 "2020-05-08T14:11:26Z")

</div>

Hi Harry,

We’ve upgraded the Kong to 2.0.4 and we noticed if there was any malformed or bad configuration in plugins then the whole functionality of Kong would go down whereas in Kong 1.4.1, it has worked perfectly and bad or malformed configuration would be ignored by Kong.

How could we solve this problem, it’s about the validation of plugin’s configuration ?

---

<div class="post-metadata">

### Author: ![hbagdi](https://yyz2.discourse-cdn.com/flex036/user_avatar/discuss.konghq.com/hbagdi/32/562_2.png) [@hbagdi](https://discuss.konghq.com/u/hbagdi)
#### Post date: [May 8, 2020, 9:04pm UTC](https://discuss.konghq.com/t/kong-plugin-configuration-validation/6240/2 "2020-05-08T21:04:07Z")

</div>

Are you using Kong in Kubernetes as an Ingress Controller?

---

<div class="post-metadata">

### Author: ![Hamed\_Hatami](https://yyz2.discourse-cdn.com/flex036/user_avatar/discuss.konghq.com/hamed_hatami/32/1672_2.png) [@Hamed\_Hatami](https://discuss.konghq.com/u/Hamed_Hatami)
#### Post date: [May 9, 2020, 11:00pm UTC](https://discuss.konghq.com/t/kong-plugin-configuration-validation/6240/4 "2020-05-09T23:00:52Z")

</div>

Yes, We have been using Kong in Kubernetes as an Ingress Controller. It’s really wonderful because in 1.4.1 we haven’t had that validation issue

---

<div class="post-metadata">

### Author: ![Hamed\_Hatami](https://yyz2.discourse-cdn.com/flex036/user_avatar/discuss.konghq.com/hamed_hatami/32/1672_2.png) [@Hamed\_Hatami](https://discuss.konghq.com/u/Hamed_Hatami)
#### Post date: [May 11, 2020, 9:11am UTC](https://discuss.konghq.com/t/kong-plugin-configuration-validation/6240/5 "2020-05-11T09:11:17Z")

</div>

Moreover, Due to Openshift 3.x doesn’t support “admission controller” in production level, we’re not able to use this feature to solve our problem.

[https://docs.openshift.com/container-platform/3.9/architecture/additional\_concepts/dynamic\_admission\_controllers.html](https://docs.openshift.com/container-platform/3.9/architecture/additional_concepts/dynamic_admission_controllers.html)
