# Kong installation on MacOS - DBless mode

**URL:** <https://discuss.konghq.com/t/kong-installation-on-macos-dbless-mode/8329>\
**Category:** General\
**Created:** [May 3, 2021, 9:07pm UTC](https://discuss.konghq.com/t/kong-installation-on-macos-dbless-mode/8329 "2021-05-03T21:07:41Z")\
**Posts on this page:** 1\
**Page:** 1

<div class="post-metadata">

**Author:** ![cp6023](https://avatars.discourse-cdn.com/v4/letter/c/57b2e6/32.png) [@cp6023](https://discuss.konghq.com/u/cp6023)\
**Post date:** [May 3, 2021, 9:07pm UTC](https://discuss.konghq.com/t/kong-installation-on-macos-dbless-mode/8329/1 "2021-05-03T21:07:41Z")

</div>

I tried installing Kong in DBless mode following the documentation - [Install - macOS | Kong - Open-Source API Management and Microservice Management](https://docs.konghq.com/install/macos/?_ga=2.165599355.53162358.1619461148-666229585.1618341082).

I was able to follow the steps as mentioned.

Changes i made -  
Copied kong.config.default to another location and changed config:  
database = off  
declarative\_config = /path/to/kong.yml

but when i tried starting it, - it throws an error as below:

```
> kong start --v -c /Users/path to/kong.conf.default
> 
> 2021/05/03 13:37:20 [verbose] Kong: 2.4.0
> 
> 2021/05/03 13:37:20 [verbose] reading config file at /Users/kong.conf.default
> 
> 2021/05/03 13:37:20 [verbose] prefix in use: /usr/local/opt/kong
> 
> 2021/05/03 13:37:20 [verbose] preparing nginx prefix directory at /usr/local/opt/kong
> 
> 2021/05/03 13:37:20 [verbose] SSL enabled on
> 
> 2021/05/03 13:37:20 [verbose] proxy SSL certificate found at /usr/local/opt/kong/ssl/kong-default.crt
> 
> 2021/05/03 13:37:20 [verbose] proxy SSL certificate found at /usr/local/opt/kong/ssl/kong-default-ecdsa.crt
> 
> 2021/05/03 13:37:20 [verbose] SSL enabled on
> 
> 2021/05/03 13:37:20 [verbose] admin SSL certificate found at /usr/local/opt/kong/ssl/admin-kong-default.crt
> 
> 2021/05/03 13:37:20 [verbose] admin SSL certificate found at /usr/local/opt/kong/ssl/admin-kong-default-ecdsa.crt
> 
> 2021/05/03 13:37:20 [warn] ulimit is currently set to "2560". For better performance set it to at least "4096" using "ulimit -n"
> 
> Error:
> 
> /usr/local/share/lua/5.1/kong/cmd/start.lua:33: [PostgreSQL error] failed to retrieve PostgreSQL server_version_num: FATAL: could not open file "global/pg_filenode.map": Operation not permitted
> 
> stack traceback:
> 
> [C]: in function 'assert'
> 
> /usr/local/share/lua/5.1/kong/cmd/start.lua:33: in function 'cmd_exec'
> 
> /usr/local/share/lua/5.1/kong/cmd/init.lua:88: in function </usr/local/share/lua/5.1/kong/cmd/init.lua:88>
> 
> [C]: in function 'xpcall'
> 
> /usr/local/share/lua/5.1/kong/cmd/init.lua:88: in function </usr/local/share/lua/5.1/kong/cmd/init.lua:45>
> 
> /usr/local/bin/kong:9: in function 'file_gen'
> 
> init_worker_by_lua:49: in function <init_worker_by_lua:47>
> 
> [C]: in function 'xpcall'
> 
> init_worker_by_lua:56: in function <init_worker_by_lua:54>
> 
> user@machine ~ % kong start -c kong.conf.default
> 
> 2021/05/03 13:44:26 [warn] ulimit is currently set to "2560". For better performance set it to at least "4096" using "ulimit -n"
> 
> Error: [PostgreSQL error] failed to retrieve PostgreSQL server_version_num: FATAL: could not open file "global/pg_filenode.map": Operation not permitted 

```

When i said database = off, why is it still searching for PostGreSql…(i installed the postgres initially, but then uninstalled it).

Not understanding what is going on. any pointers as to what to do next?
