Kong Ingress Controller ignores its configuration

Hey there,

We are seeing a very random behavior with both Kong 1.5 and 2.0 using the Kong Ingress Controller.
Kong doesn’t starts well and seems to ignore its configuration (so it only partially serve contents, with its own certificate, but yeah ,it’s broken).

Happened on production multiple time, and the last time, we desperately restarted and killed random KongIngresses/Plugins it until it finally gets back to normal operations. But the crash happens without any change on our side (the Kong pod restarts for whatever reason (killed manually, etc), and is just broken after).

Example of logs we can see :

127.0.0.1 - - [16/Jun/2020:14:46:53 +0000] "POST /config?check_hash=1 HTTP/2.0" 500 142 "-" "Go-http-client/2.0"
2020/06/16 14:46:56 [error] 22#0: *11 [kong] api_helpers.lua:260 Cannot serialise table: excessively sparse array, client: 127.0.0.1, server: kong_admin, request: "POST /config?check_hash=1 HTTP/2.0", host: "localhost:8444"

Posted an issue here : https://github.com/Kong/kubernetes-ingress-controller/issues/746 that suggest us to do the upgrade, but I can’t afford to re-try an upgrade for now, plus another user had this issue with a newer version also.

We are using Kong Ingress Controller in DBless mode on a EKS cluster.

Do you know what’s happening ?

Thanks for your help

What is the version of ingress controller and kong (including the patch version)?

Here you are :

  • Kong v1.5.0
  • Ingress Controller v0.7.1

This behavior was first seen after an upgrade to Kong v2.0.0 + Ingress Controller v0.9.0. We rollbacked everything but the error was still here.

Please upgrade Kong to 2.0.5.There are bunch of bugs fixes in those 5 patch releases:


© 2019 Kong Inc.    Terms  •  Privacy  •  FAQ