Error from Kong-Ingress-Control initContainer


#1

Hi,

I installed Kong 0.14, Kong-Ingress-Controller 0.2 and use Cassandra 3.11.

I am getting the following error from Kong-Ingress-Control. initContainer

Error: [cassandra error] Error during migration 2016-02-25-160900_remove_null_consumer_id: [cassandra error] failed waiting for schema consensus: timeout

Run with --v (verbose) or --vv (debug) for more details

I was reading https://github.com/Kong/kong/issues/3005, and it mentioned about “… increasing the cassandra_schema_consensus_timeout parameter to 2 minutes (=120000ms)…”. I would like to know how to configure in Kong-Ingress-Controller yaml file.

The cassandra endpoint is - cassandra.default.svc.cluster.local

Thanks.


#2

Hello @chlung

You should be able to tune cassandra_schema_consensus_timeout by setting the corresponding environment variable: KONG_CASSANDRA_SCHEMA_CONSENSUS_TIMEOUT.

Since you’re encountering this issue with migration, you’ll need to set the environment variable in the init container:

If this answers your question, please mark the post as solved by clicking the checkbox at the bottom of this comment. Thanks!


#3

Thanks. Let me give it a try.


#4

@hbagdi Thanks for your help. My issue is resolved which is caused by Cassandra resource issue. I really don’t need to set up the above timeout environment variable.