# ERROR BUFFER HEADER KONG HELM CHART "Upstream sent too big header while reading response header from upstream"

**URL:** <https://discuss.konghq.com/t/error-buffer-header-kong-helm-chart-upstream-sent-too-big-header-while-reading-response-header-from-upstream/5018>\
**Category:** Questions\
**Created:** [November 27, 2019, 11:33pm UTC](https://discuss.konghq.com/t/error-buffer-header-kong-helm-chart-upstream-sent-too-big-header-while-reading-response-header-from-upstream/5018 "2019-11-27T23:33:06Z")\
**Posts on this page:** 4\
**Page:** 1

<div class="post-metadata">

**Author:** ![jorge.guega](https://avatars.discourse-cdn.com/v4/letter/j/59ef9b/32.png) [@jorge.guega](https://discuss.konghq.com/u/jorge.guega)\
**Post date:** [November 27, 2019, 11:33pm UTC](https://discuss.konghq.com/t/error-buffer-header-kong-helm-chart-upstream-sent-too-big-header-while-reading-response-header-from-upstream/5018/1 "2019-11-27T23:33:06Z")

</div>

Good morning,  
I need help I have an error in the kong **“upstream sent too big header while reading response header from upstream”** I think I need to increase buffer header in nginx but I am using the helm chart [https://hub.kubeapps.com/charts/stable/kong](https://hub.kubeapps.com/charts/stable/kong) and I don’t know how to modify these values ​​since they are internal to nginx How can I modify these values?  
proxy\_buffer\_size 128k;  
proxy\_buffers 4 256k;  
proxy\_busy\_buffers\_size 256k;  
it’s very urgent, thank you for your help

---

<div class="post-metadata">

**Author:** ![hbagdi](https://yyz2.discourse-cdn.com/flex036/user_avatar/discuss.konghq.com/hbagdi/32/562_2.png) [@hbagdi](https://discuss.konghq.com/u/hbagdi)\
**Post date:** [November 28, 2019, 2:47am UTC](https://discuss.konghq.com/t/error-buffer-header-kong-helm-chart-upstream-sent-too-big-header-while-reading-response-header-from-upstream/5018/2 "2019-11-28T02:47:56Z")

</div>

You can use nginx directive injection feature of Kong to inject these into Kong’s configuration using environment variables (env section in Helm chart’s values.yaml file):

[https://docs.konghq.com/1.2.x/configuration/](https://docs.konghq.com/1.2.x/configuration/)

---

<div class="post-metadata">

**Author:** ![jorge.guega](https://avatars.discourse-cdn.com/v4/letter/j/59ef9b/32.png) [@jorge.guega](https://discuss.konghq.com/u/jorge.guega)\
**Post date:** [November 28, 2019, 8:12am UTC](https://discuss.konghq.com/t/error-buffer-header-kong-helm-chart-upstream-sent-too-big-header-while-reading-response-header-from-upstream/5018/3 "2019-11-28T08:12:28Z")

</div>

Thanks for your answer, I am using as follows in values.yaml:  
env:  
database: postgres  
proxy\_access\_log: /dev/stdout  
admin\_access\_log: /dev/stdout  
admin\_gui\_access\_log: /dev/stdout  
portal\_api\_access\_log: /dev/stdout  
proxy\_error\_log: /dev/stderr  
admin\_error\_log: /dev/stderr  
admin\_gui\_error\_log: /dev/stderr  
portal\_api\_error\_log: /dev/stderr  
admin\_listen: 127.0.0.1:8444 ssl  
client\_body\_buffer\_size: 512k  
client\_header\_buffer\_size: 512k  
http2\_max\_field\_size: 512k  
http2\_max\_header\_size: 512k  
ssl\_buffer\_size: 512k

Do I have to use the nginx\_http\_ prefix in the env section?

For example if I want to add: proxy\_buffer\_size  
I should use in the env section: nginx\_proxy\_proxy\_buffer\_size  
It’s correct?  
thank you very much

---

<div class="post-metadata">

**Author:** ![jorge.guega](https://avatars.discourse-cdn.com/v4/letter/j/59ef9b/32.png) [@jorge.guega](https://discuss.konghq.com/u/jorge.guega)\
**Post date:** [November 28, 2019, 9:38am UTC](https://discuss.konghq.com/t/error-buffer-header-kong-helm-chart-upstream-sent-too-big-header-while-reading-response-header-from-upstream/5018/4 "2019-11-28T09:38:43Z")

</div>

I solved the problem adding in values.yaml in the env section the values:  
env:  
nginx\_proxy\_proxy\_buffer\_size: 128k  
nginx\_proxy\_proxy\_buffers: 4 256k  
nginx\_proxy\_proxy\_busy\_buffers\_size: 256k  
Thank!!
