Disable logs on service

I want to remove the external load balancer healthprobe logs from the logs, so I created a simple ConfigMap with the following:

    server {
      listen 0.0.0.0:2112;

      access_log off;
      error_log off;

      location /c_health {
        return 200 "ok";
      }
    }

It is working, returning a 200 code, but I still see the load balancer requests in the access and error logs (in the error there are a lot of “client closed connection while waiting for request” info messages).

I also tried the request termination plugin (also works ok), but can’t disable the logging.

I’m using fluentbit to forward logs to a ELK environment.