Cassandra set-up

#1

Kong: 2 nodes - KC1, KC2
Cassandra: 3 nodes - all 3 in same DC - KC1, KC2, C3
(KC - denotes Kong and Cassandra are running on same host, this is lab set-up)

Consistency_Level: QUORUM
Replication_Factor: 2

  1. C* on KC2 is marked down. Read/write/proxy via Kong running on both KC1 and KC2 runs without any issues.

Consistency_Level changed to 1 on both Kong instances.

  1. C* on KC2 and C3 is marked down.

Kong on KC2 restarts fine but outputs such messages when request is made against it: " cluster.lua:427: next_coordinator(): [lua-cassandra] load balancing policy chose host at . cluster_events.lua:362: [cluster_events] failed to poll: failed to retrieve events from DB: [Unavailable exception] Cannot achieve consistency level ONE, context: ngx.timer". Question - 1: Since C* is running on KC1, shouldn’t that suffice as ONE for consistency level ?

Kong on KC1 doesn’t even restart - when tried restarting with --vv flag, it gives this error message: "/usr/local/share/lua/5.1/kong/cmd/start.lua:30: [Cassandra error] no release_version for peer " . Question - 2: I ran this query “select release_version, rpc_address from system.peers;” through cqlsh on KC1, and i got the response back with release_version (3.11.4) and IP addresses of KC2 and C1, so why the error message indicates no release_version ?

Appreciate all the help in understanding this better! Thank You!