# \[Cassandra error\] all hosts tried for query failed. 127.0.0.1: host seems unhealthy, considering it down (connection refused)

**URL:** <https://discuss.konghq.com/t/cassandra-error-all-hosts-tried-for-query-failed-127-0-0-1-host-seems-unhealthy-considering-it-down-connection-refused/6296>\
**Category:** Questions\
**Created:** [May 13, 2020, 9:31am UTC](https://discuss.konghq.com/t/cassandra-error-all-hosts-tried-for-query-failed-127-0-0-1-host-seems-unhealthy-considering-it-down-connection-refused/6296 "2020-05-13T09:31:17Z")\
**Posts on this page:** 2\
**Page:** 1

<div class="post-metadata">

**Author:** ![Salman\_Meraji](https://yyz2.discourse-cdn.com/flex036/user_avatar/discuss.konghq.com/salman_meraji/32/1897_2.png) [@Salman\_Meraji](https://discuss.konghq.com/u/Salman_Meraji)\
**Post date:** [May 13, 2020, 9:31am UTC](https://discuss.konghq.com/t/cassandra-error-all-hosts-tried-for-query-failed-127-0-0-1-host-seems-unhealthy-considering-it-down-connection-refused/6296/1 "2020-05-13T09:31:17Z")

</div>

Hello Guys,  
I try to setup a 2 node kong cluster with 2 connected cassandra databases. I’ve already installed and connected cassandra cluster as you see in below picture

 ![kongerror1](https://canada1.discourse-cdn.com/flex036/uploads/konghq/original/2X/e/e5c3d36bd4a1ec0c5bd1d1af1086b46925ba13ec.png)

BUT after I tried to run kong migration for the first time I got above error and also I got this error on each of my nodes evert time I try to run migrations

 ![kongerror1](https://canada1.discourse-cdn.com/flex036/uploads/konghq/original/2X/4/41022f404265f79c5dfe5115becf2ed13d4c485d.png)

I just change these parameters in kong.conf :  
**admin\_listen = 0.0.0.0:8001, 0.0.0.0:8444 ssl**  
**database = cassandra**  
**cassandra\_contact\_points = 127.0.0.1**  
**cassandra\_port = 9042**  
\*\*cassandra\_keyspace = kong \*\*  
**cassandra\_consistency = ONE**  
**cassandra\_timeout = 5000**  
\*\*cassandra\_ssl = off \*\*  
**cassandra\_ssl\_verify = off**  
**db\_update\_propagation = 10**

**All other parameters have default settings**

**In cassandra Yaml file both listen address and rpc address are set exactly the same local IPs which means 192.168.153.128 for one node and 192.168.153.132 for the other node**  
broadcast\_rpc\_address is not set because when I change the value of this property then cassandra database will down

I really need help about this problem , I’ll really appreciate if someone help me find the solution.

---

<div class="post-metadata">

**Author:** ![Salman\_Meraji](https://yyz2.discourse-cdn.com/flex036/user_avatar/discuss.konghq.com/salman_meraji/32/1897_2.png) [@Salman\_Meraji](https://discuss.konghq.com/u/Salman_Meraji)\
**Post date:** [May 14, 2020, 7:57am UTC](https://discuss.konghq.com/t/cassandra-error-all-hosts-tried-for-query-failed-127-0-0-1-host-seems-unhealthy-considering-it-down-connection-refused/6296/2 "2020-05-14T07:57:44Z")

</div>

This problem has been solved I just chnaged the cassandra contact point value to the host local ip address and then It works like a charm
