Cannot delete new workspaces. Ideas?

Just installed Kong 2.2.0.0. Have it all setup.
Started creating new workspaces and mis-spelled a couple. No big deal, just delete and recreate.
Unfortunately, I cannot delete these brand new workspaces.
They are new, so there are no entities contained within.
When I try to delete, I get the error ‘Workspace is not empty’.
I’ve tried deleting via GUI and API, and same error each time.

Any ideas?
Thanks!

Hello,

We apologize for the inconvenience. Kong is aware of this issue. Though you believe it is empty there can still be other database entries associated with the Workspace that are preventing the deletion. These could be Portal files (if the Portal was enabled), Entities and Roles (as you mentioned) or other metadata. Our Product team is working on the fix and unfortunatley we currently do not have an official workaround.

The Customer Experience team will post a new KB around this issue and raise a PR for Docs for consideration to the Release Notes.

Thank you for your response.

I was just able to resolve this less than 5 minutes ago. We did not enable the Dev Portal.
When workspaces are created, there are 4 associated roles that also get provisioned automatically at creation time.
While it wasn’t obvious to me initially, I found that deleting these roles for this workspace finally allowed me to ultimately delete the workspace without error.
Thanks again for your response!
James


© 2019 Kong Inc.    Terms  •  Privacy  •  FAQ